Post Format

Old Avid Software on Mac OS X El Capitan

201506-omaha-5.jpgLittle strikes fear in the hearts and minds of music production engineers like upgrading to a new version of Mac OS X. Will their precious (and often expensive) music software applications continue to work as expected, or will they fail in some unforeseen catastrophic way?

I usually wait months — if not years — before upgrading to a new OS X release, but since I do work not only with music but also with software development, I wanted a newer version of Apple Xcode, which I had been delaying installing for the past year, concerned about upgrading my operating system to OS X Yosemite. When Apple released OS X El Capitan earlier this week, I figured I might as well jump all the way to El Capitan, and fight whatever software update battles may lie ahead.

So how did things turn out?

  • Avid Sibelius First 6: The “lite” version of Avid Sibelius, I have been running this for several years. I was pleasantly surprised to find no problems running this under El Capitan.
  • Avid Pro Tools 10: With Avid up to Pro Tools 12 now, I strongly suspected that Pro Tools 10 might explode in some horrific way, and, with credit card in hand, was prepared to upgrade if necessary. Again though, I was pleasantly surprised at the outcome. As was reported under OS X Yosemite, there are some minor graphical glitches when browsing menus, but that problem is reasonably surmounted. Otherwise the software seems to work as expected. I recorded a quick demonstration piece in Pro Tools, which also exercised Native Instruments Kontakt 5, Addictive Drums, and Valhalla Room reverb.
  • Adobe Lightroom 5: Not an audio application, but another major piece of software that I use frequently. No issues under El Capitan that I can see.

[In every case, the software had already been installed as of my previous Mac OS X Mavericks setup, which I upgraded to El Capitan. I have heard that at least some older Avid software won’t install from scratch on El Capitan.]

The biggest surprise was when I turned on my Focusrite Saffire PRO 40 audio interface, and the Saffire mix control software on the computer failed to see the hardware unit. Focusrite’s website claims that the Saffire PRO 40 works under OS X El Capitan with the latest Saffire MixControl 3.6 software, which I installed, so what was wrong?

I eventually found a helpful tidbit elsewhere on Focusrite’s website that explains, when upgrading MixControl software, there is an old library file that you need to manually delete before the hardware connection works properly. I followed the instructions, and all was well.

The bottom line: I could easily continue using all of the old software applications that I have tried so far under OS X El Capitan without significant issue. I will probably upgrade to Pro Tools 12 (or possibly move to another DAW package) soon, but Pro Tools 10 is still quite functional, so no hurry.

Leave a Reply

Required fields are marked *.